P0113 code came up on my sons PJ Ranger, anyone know a fix?

Got a problem or suggestion relating to oil burners? Post it here
axm313
I'm new, be nice!
Posts: 5
Joined: December 24th, 2018, 8:02 pm

P0113 code came up on my sons PJ Ranger, anyone know a fix?

Unread post by axm313 » December 26th, 2018, 10:25 pm

does anyone know how to fix po113 code on pj ranger says its intake air temp

Les - PK Ranger
Part of the furniture
Posts: 1159
Joined: December 5th, 2011, 8:39 pm

Re: P0113 code came up on my sons PJ Ranger, anyone know a fix?

Unread post by Les - PK Ranger » December 27th, 2018, 10:09 am

Code is high voltage signal from the intake air temperature (IAT) sensor.

It may be a once of freak thing . . . if so, then they can clear themsleves after a few starts / stops of the ignition.
If that fails, disconnecting the battery for a good hour (or better overnight) will reset things, and may or may not reset check engine light (CEL).
The code may be stored in the background, or disappear totally.

With P0113 error, it indicates the powertrain control module (PCM) receives a return voltage of 4.91 volts or more from the IAT.
There is a problem between the IAT sensor and PCM, and could be a faulty or loose sensor, or connection problem.
Maybe start by checking those, and it may be a new IAT sensor is needed if nothing easy is found like the sensor loose, or connection faulty or dirty etc.

Google the code, which is P0113 (P zero113) and you will find lots of info.
Google IAT sensor location and PCM location, you should get pics etc to help find them and look for errors.

Let people here know how you go and if you solve it ok.

axm313
I'm new, be nice!
Posts: 5
Joined: December 24th, 2018, 8:02 pm

Re: P0113 code came up on my sons PJ Ranger, anyone know a fix?

Unread post by axm313 » December 27th, 2018, 12:35 pm

thanks for reply les ,is the iat sensor part of the maf sensor or is it completely separate having trouble finding info on it

Les - PK Ranger
Part of the furniture
Posts: 1159
Joined: December 5th, 2011, 8:39 pm

Re: P0113 code came up on my sons PJ Ranger, anyone know a fix?

Unread post by Les - PK Ranger » December 28th, 2018, 5:15 pm

Hmm, good question.
It is often part of a MAF sensor if one is fitted, but apart from cleaning the MAF (and MAP) sensors a few times over the years, I haven't had a need to check IAT (if it is separate).

I'm in Adelaide and my Ranger is in Brisbane at the moment, so I can't check . . . are there 6 wires coming from the MAF ? (If this is visible, or look at the plug, does it have 6 pins ??)
Apparently MAF with inbuilt IAT has 6 wires, but without the IAT there's only 4 wires.

Return to “Diesel Tech”