I'm getting Great support for my Foton Tunland!

If you've got model specific Tech questions &/or answers but you're not covered elsewhere, put them in here!
Dmaxqld
Been here a while
Posts: 364
Joined: November 28th, 2013, 12:01 pm

Re: I'm getting Great support for my Foton Tunland!

Unread post by Dmaxqld » March 30th, 2018, 9:28 am

DPFs should regenerate every 300-500kms. Suggest you haven’t noticed or don’t have a DPF.

Scantek
Been here a while
Posts: 325
Joined: October 29th, 2008, 6:55 pm
Location: Geraldton, WA

Re: I'm getting Great support for my Foton Tunland!

Unread post by Scantek » March 30th, 2018, 12:43 pm

Hi
Being a Euro5 compliant build it should have one. I would think.
I had a look under neath and couldn't see one anywhere with all the under body guards.
Then I noticed that there was a Foton DPF for sale on Ebay.
Apparently it is right up near the turbo and it isn't very big. I couldn't see any injector ports on it so I assumed it was part of the exhaust manifold.
If its that close to the turbo maybe it re-gens when under heavy load when the turbo is working hard and the EGT's are up in the high range....

But no I haven't noticed any performance drop or the DPF Re'Gen light come on at all hence why I asked.

Has anyone else noticed a re-gen happening?

cheers

Russ

mack1508
Getting to know the place
Posts: 12
Joined: February 21st, 2018, 8:08 pm

Re: I'm getting Great support for my Foton Tunland!

Unread post by mack1508 » April 1st, 2018, 1:54 pm

Hi Russ. Yes mine does the same thing. The DPF you are referring to is that the Diesel Particulate Filter and if so where is it as I have changed my muffler to a high flow one.Regards Phil

Scantek
Been here a while
Posts: 325
Joined: October 29th, 2008, 6:55 pm
Location: Geraldton, WA

Re: I'm getting Great support for my Foton Tunland!

Unread post by Scantek » April 1st, 2018, 7:50 pm

Hi Phil
I cant actually see it on mine but looking at a picture of an engine on Ebay out of a Tunland, the exhaust does a 90 degree straight after the turbo with a cast iron elbow and the DPF hangs off the end of that with a HD band clamp.
So it would be in the hottest part of the exhaust gas. I cant see any injector on it though.

Link below

https://www.ebay.com.au/itm/FOTON-TUNLA ... SwnlFaa8GP

Russ

cmar
Avid Poster
Posts: 946
Joined: December 28th, 2010, 11:09 pm

Re: I'm getting Great support for my Foton Tunland!

Unread post by cmar » April 21st, 2018, 9:53 am

If you can't see pipes and sensors attached that's possibly a close coupled catalytic converter, not a DPF. You don't necessarily need a DPF to comply with Euro 4/5 if the engine is well engineered. My Santa Fe 2.2 R series diesel doesn't have one., yet the mirror image Kia Sorento twin does?
Haven't owned a 2WD since 1982.

Scantek
Been here a while
Posts: 325
Joined: October 29th, 2008, 6:55 pm
Location: Geraldton, WA

Re: I'm getting Great support for my Foton Tunland!

Unread post by Scantek » April 24th, 2018, 8:57 pm

Hi cmar

Yes that did cross my mind about it being a Cat but it was listed on Ebay as a DPF .
I couldn't see any sensors or injector lines either thats why I asked the question.
I did think you needed a DPF for Euro 4/5 complience though and the dash does have a DPF Re-gen light hence my confusion.

Sorry for taking so long getting back but had an un-planned stay in hospital for a week & a bit after Easter

cheers

Russ

Scantek
Been here a while
Posts: 325
Joined: October 29th, 2008, 6:55 pm
Location: Geraldton, WA

Re: I'm getting Great support for my Foton Tunland!

Unread post by Scantek » July 10th, 2018, 11:28 pm

Hi everyone
Update:
Well had my Ute looked at a few weeks ago and spoke with the new service manager. The flat spot that is apparent is there and part of it. The only solution to this is an ECU re-map. He gave me the name of a company that does re-map in a way that saves the original map as a reset and dynotunes to your requirements. Not sure if I'm going to go that way or not.
The flat spot is more noticeable in the Tunland as they have a higher 1st gear than other items. If you received it higher on take off it's not noticeable.
As for the slipping clutch issue I had, that looks like it's all fixed. From what I've been told it's caused by a faulty spring in the clutch vaccum booster that weakens when it gets hot so deleting this part of the clutch system is the go.

Other than that, all else is going well😁

mack1508
Getting to know the place
Posts: 12
Joined: February 21st, 2018, 8:08 pm

Re: I'm getting Great support for my Foton Tunland!

Unread post by mack1508 » July 11th, 2018, 7:51 pm

Hi, Phil here. Do not bother to have it re mapped as it does not work on the cummins. Spoke with Foton mechanic here in Victoria and he told me all the issues with the throttle. He told me off the record to get a blanking plate and blank the EGR off at the exhaust side. The pipe that goes from the top of the exhaust manifold to the inlet is the one you blank off. Look on the internet for the blank plate for the Tunland. I did mine and what a magnificent difference . Trust me it works . No check engine light or any thing. Absolutely happy with it. Regards, Phil.

Scantek
Been here a while
Posts: 325
Joined: October 29th, 2008, 6:55 pm
Location: Geraldton, WA

Re: I'm getting Great support for my Foton Tunland!

Unread post by Scantek » July 21st, 2018, 2:41 pm

Hi Phil
Thanks for that. I was told that blanking the EGR has great benefits and makes a big difference in fuel efficiency.
My old Ford Ranger would show a check engine light if it was blanked. I was reluctant to do that to the Foton for the same reason.
The Foton dealer over here said that he has seen a lot of crap remaps done but he knows of one guy that does a good one and if for some reason it corrupts it defaults back to OEM. Not sure that I want anyone messing with my ECU no matter who they are.
I'll give the blank plate a go though.

Can you tell me how different Your Tunland is and elaborate a little?

I have been told to upgrade the earth's as well as this makes a difference

Many thanks

Russ

Scantek
Been here a while
Posts: 325
Joined: October 29th, 2008, 6:55 pm
Location: Geraldton, WA

Re: I'm getting Great support for my Foton Tunland!

Unread post by Scantek » July 21st, 2018, 2:43 pm

Does anyone know of or have an OBD scanner that works on the Tunland?

mack1508
Getting to know the place
Posts: 12
Joined: February 21st, 2018, 8:08 pm

Re: I'm getting Great support for my Foton Tunland!

Unread post by mack1508 » July 23rd, 2018, 8:33 pm

Hi Russ. Since I put the blank plate in it is a total different ute to drive. There is no hesitation or check eng light. The best bit of coin I have spent on it. The earth leads are a must as there is no engine to body ground any where. The only prob you will have is, the one behind the brake lines on the right side. Just make a new one and ground it to the fire wall. I ran an extra earth from battery to the earth on left side loom, then from there to the right side of ute and from there to an engine bolt on the egr. Later, I am going to do one from the body to chassis. The wire I used was the thick battery cable all round except for the one behind the brake lines. Make sure you buy the blank plate that totally blocks it off and not one with a hole. I will try and find the web site I purchased mine from and put it up here for you. With out the blank plate, the computer thinks it has an intake leak somewhere when using very little throttle, as the egr on these close off after a quarter throttle. Best of luck mate you will not be disappointed. Regards Phil

Scantek
Been here a while
Posts: 325
Joined: October 29th, 2008, 6:55 pm
Location: Geraldton, WA

Re: I'm getting Great support for my Foton Tunland!

Unread post by Scantek » September 5th, 2018, 4:53 pm

Hi Phil
Finally did the blanking off of the EGR. I measured the flange and made one out of a piece of sheet metal I had laying around. I made it from a piece of 0.6mm sheet thinking I would keep it thin so as not to have too much deflection between the flanges. But on close inspection it has a flexible joint in that pipe so I could have made it thicker. Sealed it up with some Loctite 515 and all good.
I took it for a short drive and I can't believe the difference. The hesitation has gone. Very happy.
Many thanks Phil 😁. And no check engine light!!!!!
Have you noticed any change in your fuel consumption Phil?
If anyone wants the dimensions of the blank plate PM me and I will be happy to send to you.

Just need to do the new earth grounding now

Many thanks again Phil

mack1508
Getting to know the place
Posts: 12
Joined: February 21st, 2018, 8:08 pm

Re: I'm getting Great support for my Foton Tunland!

Unread post by mack1508 » September 6th, 2018, 9:19 pm

Hi Russ glad you are happy. On the, no difference in fuel still getting 7.4 to 8 and just a pleasure to drive.

Scantek
Been here a while
Posts: 325
Joined: October 29th, 2008, 6:55 pm
Location: Geraldton, WA

Re: I'm getting Great support for my Foton Tunland!

Unread post by Scantek » September 11th, 2018, 12:13 am

I used to get a gift of black smoke on take off when it hesitated but that seems to have gone as well.
I do keep a log of my fuel usage and economy so if there is any change to that I'll let you know. I have fuelled up since I did the blank off but I had to tow a trailer so if there is any improvement I won't know till I refuel after this tank. So far, I have done about 200kms towing and the fuel needle has moved about 1/8th on the guage and still showing 8.4l per 100km but I have this is not very accurate.
Will keep updating

Cheers
Russ

Scantek
Been here a while
Posts: 325
Joined: October 29th, 2008, 6:55 pm
Location: Geraldton, WA

Re: I'm getting Great support for my Foton Tunland!

Unread post by Scantek » November 7th, 2018, 9:15 pm

Update on my Tunland

Ok just got new tires and a wheel alignment.
I had creak somewhere in the front end of my Tunland. I greased all the ball joints but still creaked when reversing on wheel lock.
After the new tires and alignment no creak and the front wheels seem to sit differently. Apparently the alignment specs are the same as a Hilux.
I had a genuine SS nudge bar put on pre delivery and shortly after I added 2 X Light force 220 spotlights.
These might weigh 10kgs at most combined so you wouldn't think they would put the wheel alignment out. Well they do. So far out that it makes the front end creak.
Now that's fixed it just seems much better to drive.

If you get a bar or anything at all put on make sure you get a fresh alignment. NO MATTER what the dealer says!!

Cheers

Return to “Other makes”