Random Engine power loss issue?? Advice? Testing?

oversite
Need to get out more
Posts: 2499
Joined: January 30th, 2012, 3:41 pm
Location: Armidale, NSW

Random Engine power loss issue?? Advice? Testing?

Unread post by oversite » June 16th, 2013, 8:01 am

Hi all,

Im having an issue with the engine in my '93 disco, V8 with an auto.

The engine power has been randomly disappearing?

It has happened on flat ground and hills, both engine hot and warm, full tank of fuel and low fuel.

What seems to happen is the revs drop and the power disappears? at idle the engine revs drop to <500rpm and it feels like its going to stall out (but doesn't) foot to the floor down main street, I couldn't brake 50kph? This time I pulled over and turned the car off and restarted and it was fine again? But the other day after I turned the car off after loosing power and it wouldn't start for a few minutes??

This is starting to seriously worry me, any advice as to where to look or what to test would be great!!

captain jack
I'm new, be nice!
Posts: 6
Joined: April 18th, 2010, 10:21 pm

Re: Random Engine power loss issue?? Advice? Testing?

Unread post by captain jack » June 18th, 2013, 10:11 pm

Mate, first suspicion is the fuel pump. When they start to go it can be intermittent like that. The other thing is that the distributor amp module on your vehicle is a) basically crap and B) mounted right on the distributor, where the heat kills them.
Either will give the signs you are looking at but Id be more suspicious of the fuel pump at the moment.
Hope this helps.

Return to “Discovery I”