terrano lossing power and dying Help

Terrano, 720, X-Trail
evilhighway
Getting to know the place
Posts: 12
Joined: May 11th, 2009, 8:25 am

terrano lossing power and dying Help

Unread post by evilhighway » July 16th, 2009, 11:30 am

Hi all my 1990 td 2.7 terrano has started some issues. It will be driving ok then all of a sudden it will just start losing power and eventually stop. No reving or use of the throttle adjuster makes a difference. It has now got worse and does not want to start. When it does it idles really rough and then dies. I have changed the fuel filter which was rather filthy and I have some new glow plugs on order. I was wondering whether anyone has had the same probs as Im describing. I am hoping it is not the fuel pump but have an idea it may be but Im new to diesel's so looking for some advice. If it is the fuel pump does anyone know where to get one from at all?
Thanks in advance for any help.

chinna
Here and there
Posts: 50
Joined: August 24th, 2008, 5:49 pm
Location: tassie

Unread post by chinna » July 20th, 2009, 9:54 pm

hey mate i have bad news my td27t started to run ruff as and crap power turned out my pump needed a reco cost me $800 in the end but i pulled it out my self and installed it my self as well as timed it in. what is was the drive shaft that drives the pump got a score in it and it let oil from the front cover in and fowled up the pump and it only happen when it got warm for some reson.

hope it help

Dave_STR
Banned
Posts: 2089
Joined: February 21st, 2007, 9:14 am

Unread post by Dave_STR » August 4th, 2009, 1:50 pm

There was a common problem with Terrano TD27TI engine's.

Its got me [email="!@#$%"]!@#$%[/email] what it was now, do a search. From memory it was a easy fix, it was a sensor.

Might have been caused by the speed sensor, when I think what it was I will let you know.

Dave.

undercover
Here and there
Posts: 55
Joined: April 2nd, 2009, 6:39 pm

Unread post by undercover » December 24th, 2009, 2:44 pm

hey Dave the sensor on #1 injector is knowen to play up and cause problems, was this the one you were trying to think of?
How did you get on in the end evilhighway? one place i can think of to check is in the fuel inlet port on the fuel pump, if you remove the banjo bolt (17mm socket) in some pumps there is an extra gauze safety filter that can (and does) get blocked, you just have to hook it out with a oring pick, clean it and refit it. i know its been a few months im just curious more than anything and thought i would add this incase someone is searching for a similar problem. all good.

terrano2buck
Here and there
Posts: 75
Joined: August 9th, 2010, 8:03 pm

Re: terrano lossing power and dying Help

Unread post by terrano2buck » March 17th, 2015, 9:21 pm

Mate i have a Terrano 2. If it loses power and is gutless it will be the MAF air sensor. get one off Ebay and replace it. Problem solved.

Return to “Other”