Heard the early D40 I/pump issues were fixed 4/2012, true?

skik
Been here a while
Posts: 160
Joined: June 21st, 2008, 6:43 pm

Heard the early D40 I/pump issues were fixed 4/2012, true?

Unread post by skik » November 13th, 2016, 12:03 pm

hi all looked at a 2013 D40 st Navara have heard stories of expensive repairs if injector pumps fail was told this problem was fixed in April 2012 is this true is there any major problems with newer Navs as most horror stories i hear a for 2011 and earlier vehicles
thanks Michael

mydmax
Need to get out more
Posts: 5384
Joined: August 4th, 2011, 10:43 pm

Re: Heard the early D40 I/pump issues were fixed 4/2012, tru

Unread post by mydmax » November 13th, 2016, 1:45 pm

If the injector pump fails, ie, the High Pressure pump, then the fuel rail (common) to all injectors will have fine metallic crap in it. That crap will also total injectors too. So a pump issue is a whole of fuel system issue.

Unfortunately, often dealers will simply replace the pump, sometimes cos the price goes up and the customer doesn't know the system will fail again and again. One repair done properly should solve all these issues. Continual shonky/ignorant repairers thinking they will get out of it with the best money margin often get caught when the owner finds out a few facts and studies the repair regimes used.
That stupid repair regime was often used by a Central NSW dealer and I know of a few vehicles that had multiple repairs until Fair trading made the dealers fix them properly, ie, replace the whole system to achieve a reliable state of operating.

PS; if the brand of High Pressure pump used by Nissan or any other make are the same, then the pump failure comes down to fuel cleanliness or servicing issues, ie filter not/never changed and that is a problem.

skik
Been here a while
Posts: 160
Joined: June 21st, 2008, 6:43 pm

Re: Heard the early D40 I/pump issues were fixed 4/2012, tru

Unread post by skik » November 13th, 2016, 2:37 pm

thanks Mydmax i was told the issues with injector pump failure where fixed in 2012 but cant find anything confirming this online i do relise regular maintenance is important especially with diesel and especially common rail i am planning whatever vehicle i do decide on to replace all filters so that i know for sure when they where last done

cmar
Avid Poster
Posts: 946
Joined: December 28th, 2010, 11:09 pm

Re: Heard the early D40 I/pump issues were fixed 4/2012, tru

Unread post by cmar » November 15th, 2016, 7:31 pm

All CR injector pumps irrespective of make are very susceptable to water, dirt, and adulterated fuel, several orders of magnitude more than an older style inline or "rotary" pump.
I think that a lot of the early failures which occurred in many of the first sold vehicles of various makes, were due less to the pump design, and more to continuation of various lazy and shoddy practices by owners and dealers which simply will not cut it with CR systems.

Things such as, never changing the filter, never draining the water trap, not priming the filter properly after changing, adding sump oil, fish 'n chip oil, buying cheap 'n nasty diesel from dodgy retailers to save a few cents, using wonderous untested "additives" etc.

In short; in the early days of CR in this country, the fuel wasn't ready, the dealers were not ready, and the owners were not ready....
Haven't owned a 2WD since 1982.

skik
Been here a while
Posts: 160
Joined: June 21st, 2008, 6:43 pm

Re: Heard the early D40 I/pump issues were fixed 4/2012, tru

Unread post by skik » November 18th, 2016, 7:02 pm

thanks cmar very good information from both you and mydmax

Return to “Navara”