TB42e popping sound - Dual Fuel

Oddmidge
Getting to know the place
Posts: 17
Joined: January 20th, 2015, 8:03 pm

TB42e popping sound - Dual Fuel

Unread post by Oddmidge » May 15th, 2015, 8:50 am

Hey guys,

I know a bit about mechanics but the gas has me flustered about how it integrates into the petrol system

Finally sussed this out enough to be able to post on it. I have a '94 GQ TB42 EFI. Since I've owned it, it runs great on gas but on petrol it will sometimes make a popping sound under moderate acceleration, sounds like a small backfire?. I've replaced the fuel filter recently (used a carb model one, bigger filter) and it was okay for a few days but its come back. If i change gears and accelerate slightly its fine, has power to the acceleration but any heavier and I lose power and its starts making the popping noise. Also has the normal almost stalling when starting on petrol. Note: Sometimes its completely fine, and appears to be okay after 30-40 minutes of driving.

I'm therefore thinking the following:
Fuel Sender/Pump
Coil Pack (not sure how this affects the LPG though)
Airbox leak, pulling in air (or something to do with the snorkle) (but wouldn't this affect the LPG)

mydmax
Need to get out more
Posts: 5384
Joined: August 4th, 2011, 10:43 pm

Re: TB42e popping sound - Dual Fuel

Unread post by mydmax » May 15th, 2015, 9:14 am

Maybe crap in the carby and accelerator pump a not working sufficiently or at all. Common if used on gas a while and not regular runs on petrol..

Can't be fuel pump if it runs ok after a while.
Can't be coil since it runs OK on gas.
An air leak would affect both gas and petrol if the leak is after the throttle body. But that won't get better after starting.

Oddmidge
Getting to know the place
Posts: 17
Joined: January 20th, 2015, 8:03 pm

Re: TB42e popping sound - Dual Fuel

Unread post by Oddmidge » May 15th, 2015, 9:46 am

EFI, so no carby to have crap in it.

I'm assuming a dirty MAF would also affect the Gas as well. I run it on petrol for 4-5k's every morning on my way to work and somedays its sh*thouse very loud popping (like an exhaust leak now I think about it, but can't be cause its fine on gas? right?) somedays its not so significant or irregular.

Jimmy Wood
Avid Poster
Posts: 637
Joined: July 26th, 2013, 4:06 pm

Re: TB42e popping sound - Dual Fuel

Unread post by Jimmy Wood » May 15th, 2015, 10:53 am

Pretty sure the gas is just squirted into the manifold. It wouldn't be electronically controlled at all, so sure a dirty sensor or some issue with the ECU would do it.

You might find the timing is set for gas (which has a different octan rating and burn rate than petrol - like more advanced timing I believe) so when it runs on petrol, your timing is crap, hence why it plays up under certain load conditions. Maybe the knock sensor (if it has Electronically controlled timing) is dodgy, or something along those lines.

Why don't you just run on gas all the time and forget about the petrol.

Oddmidge
Getting to know the place
Posts: 17
Joined: January 20th, 2015, 8:03 pm

Re: TB42e popping sound - Dual Fuel

Unread post by Oddmidge » May 15th, 2015, 12:52 pm

Jimmy Wood
Thanks for confirming what I thought about the Gas.

I basically only run it on gas, but seeing as I only get 300-350 out of a tank i'd like to get the petrol running all right if I can. Can get petrol almost anywhere in Vic, gas, not so likely. Plus if I can spend a couple hundred $$ or less and get it running alright on both I see it as a positive investment.

I will clean the MAF, as I have a suspicion its related to the loss of power/rev fluctuation thats happening. Similiar thing happened to the brothers lancer and I think that helped with it/fixed it.

Return to “GQ Patrol”