4runner not running right

Snoopy90
I'm new, be nice!
Posts: 9
Joined: October 14th, 2014, 8:22 pm
Location: Seaspray

4runner not running right

Unread post by Snoopy90 » November 25th, 2014, 7:55 pm

Hello all just wanting more info about why my 92 4runner SR5 (3.0L) is not running right its auto but at times its wants to stall like a manual, have no idea why please help
Cj-Higgins

typhoeus
Need to get out more
Posts: 2058
Joined: February 6th, 2011, 8:25 pm

Re: 4runner not running right

Unread post by typhoeus » November 26th, 2014, 11:46 am

so do you think its an engine issue or is it the transmission?

Snoopy90
I'm new, be nice!
Posts: 9
Joined: October 14th, 2014, 8:22 pm
Location: Seaspray

Re: 4runner not running right

Unread post by Snoopy90 » November 26th, 2014, 4:25 pm

Something with the motor, I have no idea what it would be.
Cj-Higgins

skik
Been here a while
Posts: 160
Joined: June 21st, 2008, 6:43 pm

Re: 4runner not running right

Unread post by skik » January 9th, 2015, 4:00 pm

has the torque converter failed this can cause what you describe

Snoopy90
I'm new, be nice!
Posts: 9
Joined: October 14th, 2014, 8:22 pm
Location: Seaspray

Re: 4runner not running right

Unread post by Snoopy90 » January 9th, 2015, 7:39 pm

Na coz now the computer has now gone and itwill not start at all
Cj-Higgins

Jimmy Wood
Avid Poster
Posts: 637
Joined: July 26th, 2013, 4:06 pm

Re: 4runner not running right

Unread post by Jimmy Wood » January 10th, 2015, 10:41 pm

Sure its the computer and not just the IAC valve in the throttle body? What else stops it starting - no spark or no fuel (petrol) or no glow plugs (diesel)?

Is it diesel or petrol? Is it EFI or carb?

Snoopy90
I'm new, be nice!
Posts: 9
Joined: October 14th, 2014, 8:22 pm
Location: Seaspray

Re: 4runner not running right

Unread post by Snoopy90 » January 11th, 2015, 8:26 am

Petrol 3l v6 3vze heaps of spark and penalty of fuel and checked all the vacuum lines and they are all on
Cj-Higgins

skik
Been here a while
Posts: 160
Joined: June 21st, 2008, 6:43 pm

Re: 4runner not running right

Unread post by skik » January 12th, 2015, 11:51 pm

dose it start when you crank it then die when key is released if so there will be a fault somewhere in the EFI circuit

Snoopy90
I'm new, be nice!
Posts: 9
Joined: October 14th, 2014, 8:22 pm
Location: Seaspray

Re: 4runner not running right

Unread post by Snoopy90 » January 13th, 2015, 8:57 am

Runs for about a minute or 2 then dies
Cj-Higgins

typhoeus
Need to get out more
Posts: 2058
Joined: February 6th, 2011, 8:25 pm

Re: 4runner not running right

Unread post by typhoeus » January 13th, 2015, 6:31 pm

MAF sensor?

skik
Been here a while
Posts: 160
Joined: June 21st, 2008, 6:43 pm

Re: 4runner not running right

Unread post by skik » January 13th, 2015, 10:10 pm

fuel pressure regulator could be faulty

Snoopy90
I'm new, be nice!
Posts: 9
Joined: October 14th, 2014, 8:22 pm
Location: Seaspray

Re: 4runner not running right

Unread post by Snoopy90 » January 15th, 2015, 6:30 am

Who wants it as im now just going to sell it as im over this crap with this car/4wd
Cj-Higgins

typhoeus
Need to get out more
Posts: 2058
Joined: February 6th, 2011, 8:25 pm

Re: 4runner not running right

Unread post by typhoeus » January 15th, 2015, 11:19 am

I would take the fuel line off, stick a piece of hose on it to feed into a drum & turn on ignition. see if you fave fuel pressure. if the pumps stops after 2 mins then its a fuel problem. you could hard wire the pump so it runs all the time & take it for a spin & see if it runs ok. I believe that the pump times out after a few mins if the engine is not running, so that would indicate the fuel pump circuit is faulty. It might be a simple fix like a relay that solves the poor running and other issues all at once.

Snoopy90
I'm new, be nice!
Posts: 9
Joined: October 14th, 2014, 8:22 pm
Location: Seaspray

Re: 4runner not running right

Unread post by Snoopy90 » January 15th, 2015, 11:30 am

Not a prob ill give that a shot thanks guys
Cj-Higgins

skik
Been here a while
Posts: 160
Joined: June 21st, 2008, 6:43 pm

Re: 4runner not running right

Unread post by skik » January 16th, 2015, 3:39 pm

try changing the Efi relay under the bonnet that controls power to the EFI (fuel injection, fuel pump, and ignition) if this is faulty it will kill your car dead in its track

Return to “4Runner”