Anyone broken front diff mounts?

All your Ford/Mazda Tech questions & answers
arcticwolf
Here and there
Posts: 48
Joined: September 16th, 2007, 6:52 am

Anyone broken front diff mounts?

Unread post by arcticwolf » October 2nd, 2016, 2:42 pm

Has anyone had problems with breaking the mounts on the front diff? I have broken the centre one with is a bracket/plate and now on the second time round I have broken the one that holds the drive shaft to passenger side and all the bushes are flogged out. I beefed up the centre one last time .Can't find replacements online just suspension bushes.

Peter Aawen
Admin
Posts: 20781
Joined: June 17th, 2005, 8:01 pm

Re: Anyone broken front diff mounts?

Unread post by Peter Aawen » October 2nd, 2016, 4:08 pm

Might help a little if you give us an idea about which Ford/Mazda you're having issues with! :thumb:

I busted a couple on a 'Ford' Maverick... :o
An Ex-Service person is someone who thought enough about their country & how great it is, how lucky we are to live here, to write a blank cheque made out to 'The People and Commonwealth of Australia' for the value of 'Up to & including my Life!'

arcticwolf
Here and there
Posts: 48
Joined: September 16th, 2007, 6:52 am

Bt 50 front diff mounts

Unread post by arcticwolf » October 3rd, 2016, 4:15 pm

Ok I have destroyed front and left hand side mounting brackets and the mounting rubbers on my 2007 BT50. Mazda says that they have never brought the brackets into Australia let alone sold one, has anyone had any drama and /or know where I can get new mounts other than genuine. It looks like they just won't cut it.

Return to “Ford / Mazda”