98 Hilux 3RZ-FE still running bad after head work- Ideas?

From four-bangers to dirty great V8s, get your petrol tech here
4lex
Getting to know the place
Posts: 19
Joined: March 1st, 2010, 10:37 pm

98 Hilux 3RZ-FE still running bad after head work- Ideas?

Unread post by 4lex » July 25th, 2013, 12:06 am

hello all. bought a 98 2.7 recently for cheap, it was running on 3, no smoke, good spark, oil clean, had to be a bad valve. price was right.

pulled the head sure enough #1 exhaust valve cracked. replaced the head, ground valves, shimmed them and rebuilt meticulously.

not running right. sounds like its losing compression, backfire on overrun, ecu has error code 33. my gut feel is I've ****** up the valve timing somehow, but I can't seem to find any reference to fault code 33 for this car.

any ideas?

cheers,
Alex

Hilux_Ryan
Avid Poster
Posts: 647
Joined: February 13th, 2011, 9:57 pm
Location: Alice Springs, NT

Re: 98 Hilux 3RZ-FE still running bad after head work- Ideas

Unread post by Hilux_Ryan » July 27th, 2013, 3:37 pm

Car has ABS brakes?

Quick internet see code 33 as a rear wheel speed sensor fault, probably also has ABS light on the dash?
My cruiser thread viewtopic.php?f=22&t=145966

typhoeus
Need to get out more
Posts: 2059
Joined: February 6th, 2011, 8:25 pm

Re: 98 Hilux 3RZ-FE still running bad after head work- Ideas

Unread post by typhoeus » July 27th, 2013, 3:57 pm

Is it a V V T I engine?

4lex
Getting to know the place
Posts: 19
Joined: March 1st, 2010, 10:37 pm

Re: 98 Hilux 3RZ-FE still running bad after head work- Ideas

Unread post by 4lex » July 30th, 2013, 10:55 am

Turns out 33 is ISCV. Tracing the wires I found I hadn't plugged it in. Duh.

mydmax
Need to get out more
Posts: 5384
Joined: August 4th, 2011, 10:43 pm

Re: 98 Hilux 3RZ-FE still running bad after head work- Ideas

Unread post by mydmax » July 30th, 2013, 5:45 pm

Strange that.

Return to “Petrol Tech”