2013 BT50 auto rear engine main seal leaking

hoyks
Avid Poster
Posts: 707
Joined: April 13th, 2003, 9:19 pm
Location: Marburg, QLD

Re: 2013 BT50 auto rear engine main seal leaking

Unread post by hoyks » November 8th, 2017, 7:23 pm

These came up on Newranger.net and show why the seal leaks.
Barker is a mechanic and this is what he and his old man found while poking around in there:
My old man I bought matching ranger 12 months ago . We are both mechanics with a combined 90 years experience between us. Both our rangers have the rear main leak. after beating ours heads on the proverbial wall dealing with service people. The old man said after 60 years working on my own cars I don't want some other bastard working on my car. So today we did the rear main on his car at 13000k . The good news it is not the seal surface leaking but the lack of silicone applied at block to sump surface. It took us 5 hours. Looks like the sealant used was poor quality, it had not set.
http://www.newranger.net/forums/viewtop ... =22&t=6972

Image

Image

Image

Image

Bizze1
Here and there
Posts: 55
Joined: January 22nd, 2014, 10:37 am
Location: Urunga, NSW

Re: 2013 BT50 auto rear engine main seal leaking

Unread post by Bizze1 » November 19th, 2017, 6:41 pm

Thanks hoyks for that info, I have printed it out and will see if the Mazda mechanic is interested in looking at it.
Merv
I plan on living forever..... so far so good
2011 LSU Dmax, canopy,Tough Dog suspension,cargo drawers,fridge slide, dual battery, canopy and cab roof bars, nav. system with rev. camera and TPMS, chip,3" exhaust, Al.B.Bar & 12,000lb winch, UHF,Scan Gauge,Snorkel

overload
I'm new, be nice!
Posts: 2
Joined: January 25th, 2011, 8:37 pm

Re: 2013 BT50 auto rear engine main seal leaking

Unread post by overload » November 25th, 2017, 4:10 pm

<t>This may be late,ask them to check that the back of the block is square and parallel in the vertical plane with the aluminum bottom block.On my bt50 the aluminum block did not meet up and oil was leaking from the join between the two, it was out a few thou .Answer i had a new motor fitted. Hope this makes sense</t>

Return to “PX Ranger / New BT50”