csa jackal wheels wont balance

foxy
Avid Poster
Posts: 543
Joined: August 29th, 2004, 8:29 pm

Re: csa jackal wheels wont balance

Unread post by foxy » June 8th, 2013, 6:09 pm

are yours Mazda ones or aftermarket CSA's? I was told that Mazda get the pick of the wheels (balance wise).....so factory wheels are better.

I got the Mazda ones and have had no balance issues......

deadbeatloser
Here and there
Posts: 87
Joined: November 19th, 2011, 5:52 pm

csa jackal wheels wont balance

Unread post by deadbeatloser » June 8th, 2013, 6:11 pm

just wondering if anybody else with the mazda cas wheels is having wheel balance issues as the tyres shop where i went to puchases some 285 75 16 atz's reckons that the offset on those rims causes the problem as the track of the vehicle is changed and tried to sell me some different rims and smaller tyres...any suggestions????......just did third trip to landcruiser last weekend just sliced up my maxxis's so time for a change

mholdern
I'm new, be nice!
Posts: 5
Joined: April 25th, 2013, 10:34 pm

Re: csa jackal wheels wont balance

Unread post by mholdern » June 9th, 2013, 5:22 pm

I have a set on mine with standard tyres and have no issues.

Cheers

deadbeatloser
Here and there
Posts: 87
Joined: November 19th, 2011, 5:52 pm

Re: csa jackal wheels wont balance

Unread post by deadbeatloser » June 9th, 2013, 6:13 pm

mine are mazda supplied....i payed 165 each an i see they are 1300 for 4 on ebay wtf?... i have 265 75 16 on it....

foxy
Avid Poster
Posts: 543
Joined: August 29th, 2004, 8:29 pm

Re: csa jackal wheels wont balance

Unread post by foxy » June 9th, 2013, 9:43 pm

Did you have issues with the first set? Increasing tyre width doest change the centre point from the previous set of tyres.....I dont understand why new wheels are necessary? If they are the factory wheels they have been part of ADR approval......

Redstrom
Getting to know the place
Posts: 19
Joined: April 19th, 2013, 4:07 pm
Location: Gungahlin, ACT

Re: csa jackal wheels wont balance

Unread post by Redstrom » June 10th, 2013, 2:21 pm

I have the CSA Tanami (7 spoke) on standard tyres and no issues

80mojo
Been here a while
Posts: 266
Joined: September 6th, 2006, 8:12 am
Location: Bathurst

Re: csa jackal wheels wont balance

Unread post by 80mojo » June 10th, 2013, 4:55 pm

Foxy, the issue may be with the tyrefitter not wanting to place weights on the bead on the wheel face, or not having the right size stickon weights for the backside. A car/truck wheel centre will have heavier weights to suit a specific point on the wheel, rather than heaps of smaller weights over a wider area of the wheel. At the end of the day the fitter can spend more time (more of your money) and do a tyre on wheel balance(spinning the tyre on the rim). I've had to do this a couple of times myself because BFG's are a balancing pain.
P.S. I had the CSA Tanami's on my BT and 2 of them cracked through the outer edge of the spokes.

mojo

BTMatt
Here and there
Posts: 48
Joined: October 17th, 2012, 8:10 pm

Re: csa jackal wheels wont balance

Unread post by BTMatt » July 10th, 2013, 9:40 pm

The problem is genuine Mazda wheels have a different size centre bore than the wheels supplied by a tyre store. If using aftermarket CSA wheels you need a centering ring as they have a larger size centre bore. How do I know this? I damaged one of my genuine CSA wheels and just bought them frem the local tyre store and then they found the differance.

80mojo
Been here a while
Posts: 266
Joined: September 6th, 2006, 8:12 am
Location: Bathurst

Re: csa jackal wheels wont balance

Unread post by 80mojo » July 15th, 2013, 8:43 pm

I had the hub rings on mine, didn't help my wheels though. I'm still an advocate for hub rings. Also, I've seen the case jackal wheels ( genuine Mazda acc ), without hub rings, wot the?

deadbeatloser
Here and there
Posts: 87
Joined: November 19th, 2011, 5:52 pm

Re: csa jackal wheels wont balance

Unread post by deadbeatloser » January 24th, 2016, 5:34 pm

ended up being a faulty tyre

Shann Low
Avid Poster
Posts: 765
Joined: April 2nd, 2014, 3:14 am

Re: csa jackal wheels wont balance

Unread post by Shann Low » January 25th, 2016, 10:06 am

2.5 years for an update? :lol:

Peter Aawen
Admin
Posts: 20781
Joined: June 17th, 2005, 8:01 pm

Re: csa jackal wheels wont balance

Unread post by Peter Aawen » January 25th, 2016, 11:10 am

C'mon Shann, don't complain about that!! At least we actually got an update/final resolution!! ;)


We do get some who join the Forum, ask their question (& sometimes even get stroppy if they don't get an instant answer), & get all sorts people posting up potentially helpful info in response over the next couple of weeks; but then we never hear from them again, not even if they are asked for an explanatory pic that might make answering/helping a helluva lot easier, let alone eventually hear the final resolution!! :purplex:

So maybe we shouldn't be giving those who DO contribute updates a hard time about it, even if it does take a while to get back! And you gotta admit that sometimes the Forum software doesn't make it any easier to respond in a timely manner either!

So regardless of how long it took, Thanks for the heads up deadbeat :thumb:
An Ex-Service person is someone who thought enough about their country & how great it is, how lucky we are to live here, to write a blank cheque made out to 'The People and Commonwealth of Australia' for the value of 'Up to & including my Life!'

deadbeatloser
Here and there
Posts: 87
Joined: November 19th, 2011, 5:52 pm

Re: csa jackal wheels wont balance

Unread post by deadbeatloser » January 25th, 2016, 6:08 pm

Lolol.....better late than never ....ended up puttn the bighorns on and no problems. ....just bought a new bt ....

Return to “PX Ranger / New BT50”