2013 Ranger

RicBro
I'm new, be nice!
Posts: 7
Joined: December 24th, 2015, 12:43 pm

2013 Ranger

Unread post by RicBro » January 11th, 2016, 12:34 pm

Hi all,

New on here so thought I'd post a couple of Pics of the Ranga.

Had a couple of Prados previously and older tojos...first time in a Ford.

I wanted a tray back to build up and found this one already converted to a tray. Since then have added canopy, roofrack, ARB bullbar, spotties, dual battery, CB, work lights, reverse camera, rod holder, awning etc...

I use this to tow my camper trailer. Did the Gibb River Road last year and Great central the year before. Can't wait for next adventure.

Beach photo was in Myalup last week...can see the smoke from the bush fires...

Ric
You do not have the required permissions to view the files attached to this post.

Aaron Schubert
Need to get out more
Posts: 4682
Joined: November 9th, 2009, 7:32 pm

Re: 2013 Ranger

Unread post by Aaron Schubert » January 12th, 2016, 10:59 am

Nice ranger mate. My brother just picked one up too. Are you happy with it?

Aaron
Looking for somewhere to go 4WDing in WA? Check out WA 4WD Tracks

My 80 Series Landcruiser

RicBro
I'm new, be nice!
Posts: 7
Joined: December 24th, 2015, 12:43 pm

Re: 2013 Ranger

Unread post by RicBro » January 12th, 2016, 3:38 pm

Yeah, loving it mate. Perfect for what I use it for. Some funny little glitches that I find in the build quality but that's just me being picky!

Ric

RicBro
I'm new, be nice!
Posts: 7
Joined: December 24th, 2015, 12:43 pm

Re: 2013 Ranger

Unread post by RicBro » February 3rd, 2016, 2:43 pm

So, After finding my battery flat repeatedly if I didn't drive for a couple of days, I went Ford and asked them to disable the Smart Charge Module. No problems, just $150 for them to do the 5 minutes work. Add on another $250 for a new battery...

A bit annoying when it is a known problem....

Return to “Utes”