Problem Solved? - 2006 TJ Engine flat spot

hooray
Here and there
Posts: 59
Joined: November 13th, 2005, 4:03 pm

Problem Solved? - 2006 TJ Engine flat spot

Unread post by hooray » April 20th, 2009, 9:06 pm

Quote from ausjeepoffroad.com.au regarding the flat spot problem.
Hope this helps.

"I bought my TJ with 175000klms on it and it had all of the problems listed above. Thinking it was age and a noisy engine it didn't think much of it untill I did the build up which included a engine rebuild. Once it was back on the road it was still driving like a dog under load. Gas analyser, scan tool all showed a engine running beautiful, but still run like a dog under load. A lean miss fire was the culprit but where? TPS changed, O2 sensor changed, Injectors cleaned and retro fitted inline fuel filter changed. Much better to drive but still a problem under load, it was time to stop guessing and a 4 wheel Dyno was next and the problem was found straight away. TJ's have a low pressure fuel delivery system that runs at 4bAR pressure. Mine was running at 2.5 bAR and when unload 1.5 bAR and the computer was over fueling by 20%, it was the fuel pump. I changed it over with a Bosch one for a third of the price of a genuine Jeep one and what a difference, it flys now with smooth acceleration, more responsive to throttle input and heaps more power. Finally solved, hopefully this my help others.
A inline fuel filter is good insurance as the filter on the fuel pump is very ordinary.
Hooray

outback growler
Here and there
Posts: 30
Joined: December 19th, 2009, 11:57 am

Unread post by outback growler » December 22nd, 2009, 9:00 pm

Thanks for the Info and I'm glad to hear you solved your problem. I just bought a '06TJ and will keep this in mind FOR SURE!!

toby84
Getting to know the place
Posts: 12
Joined: April 7th, 2010, 8:17 pm
Location: Auckland, New Zealand

Unread post by toby84 » April 15th, 2010, 3:14 pm

Hi,
do you know if this affects all TJ's of just the '06 TJ's?? im looking at a '00 TJ and am wondering if it will have the same problem.

cheers, Toby

jeepzilla
I'm new, be nice!
Posts: 5
Joined: March 7th, 2012, 2:17 pm

Re: Problem Solved? - 2006 TJ Engine flat spot

Unread post by jeepzilla » March 21st, 2012, 8:58 am

Hi

I bought a 05 tj last yr and i am having a problem with mine it going great but is going throught fuel fast i get about 450km to a tank and now im only getting 250km to a take could this be the same problem u had or something different.

Cheers justin

Troopyman
Been here a while
Posts: 383
Joined: January 21st, 2007, 1:30 pm

Re: Problem Solved? - 2006 TJ Engine flat spot

Unread post by Troopyman » April 3rd, 2012, 9:03 am

If you have a 4ltr jeep run 98 premium unleaded . You will get much better fuel economy .

jeepzilla
I'm new, be nice!
Posts: 5
Joined: March 7th, 2012, 2:17 pm

Re: Problem Solved? - 2006 TJ Engine flat spot

Unread post by jeepzilla » April 3rd, 2012, 1:26 pm

hi

i have tried the 98 premium unleaded and i still go through it at a fast rate i got it looked at and he did a duno on my car and it looks to be running smoothly. So now im looking at the ecu chip and the fuel pump and also the fuel lines to see if that will fix the problem.

Return to “TJ Wrangler”