Mylink Dev Mode Help needed?!

SomeCant
Been here a while
Posts: 173
Joined: May 5th, 2014, 4:09 pm
Location: WA

Mylink Dev Mode Help needed?!

Unread post by SomeCant » February 24th, 2017, 4:01 pm

i am looking for someone that is computer savvy to help me recover some files lost to my memory stick stopping working.

its just a copy of some of the files in the mylink, the exes for the apps etc nothing personal or vehicle specific.
this requires you to enter the development mode on the mylink and enter explorer mode (windows ce desktop) and copy a folder to a memory stick zip it and upload it.

if someone could help that would be great, if not thats ok too :D


first off make sure you have a memory stick in the usb slot with 200mb free space.

its also best to use something like a stylus or a pen with the plastic lid on as it is more precise when tapping in windows ce

to access development mode tap where the red square is 10 times fast
Image

that will bring up the box to enable development mode like this
Image

enter 20110827 into that and tap ok, it will do nothing...

go to settings from the home screen and scroll down to the last page and you should have this.
Image
tap on development mode then scroll down to Explorer Mode and tap on it.

you will be on the desktop of windows ce now
Image

double tap my device and double tap storage card
Image

tap the system folder once then in the top menu tap edit and then tap copy don't tap cut or anything else just copy.
Image

now in the top menu you will see a blue back arrow tap it to get back to the main list of folders and drives
Image

double tap the MD drive which is the usb stick and in the top menu tap edit and then tap paste.
this should copy the system folder to the memory stick.

that's it for the mylink to exit the explorer mode just turn the vehicle off take key out and lock the door and the mylink will reset after about a minute.

once that's done take the memory stick to a pc and zip the system folder and upload it for me if you can.


if you are not comfortable doing this then dont worry i will just wait until my next service and have the dealer flash the firmware back onto it.

you might be wondering why are you doing this to your mylink.
well in europe on the chevy mylinks they have added VIM to enable video while driving and MirrorLink for android phones and this does not work properly on the holden mylink and i am trying to port this over to the holden mylink.

i have lost my steering wheel controls and reverse camera using the europe firmwares.
i was half way through getting the holden one to work and my memory stick crapped out and i lost my original files.

Image

getting mirrorlink to work will allow you to plugin your android phone and operate it through the mylink unit
giving you all the apps and navigation that the phone has and not be locked to that crap bringo.

_pace
I'm new, be nice!
Posts: 9
Joined: February 3rd, 2016, 10:43 am

Re: Mylink Dev Mode Help needed?!

Unread post by _pace » February 24th, 2017, 9:13 pm

Very crafty SomeCant. This is something I will follow with interest. Look forward to a tutorial on the implementation. Sorry though I'm not savvy with your request.

Perhaps you could assist me something, when your time prevails. My C7 frustrates me with NOT having auto on/off sensing headlights. Was in the Holden dealer earlier this week (45k service) and was snooping around the showroom at the new models. I noticed current Colorado is now fitted with auto headlight switch.

Q: would be much to integrate into RG model? OR is there a kit module available to your knowledge?

Cheers Pace.
2015 Colorado7 LTZ auto - OBD2 via Torque App, full roof tray, combo LED bar.

SomeCant
Been here a while
Posts: 173
Joined: May 5th, 2014, 4:09 pm
Location: WA

Re: Mylink Dev Mode Help needed?!

Unread post by SomeCant » February 24th, 2017, 10:28 pm

lucky enough i scored a mylink today out of a 2014 collie for $150 on ebay so i can get the needed files from it as long as it works just have to wait for postage now :D

ebay has conversions for other vehicles which pretty much add a light sensor to the dash switch and it will turn the lights on when it gets dark when its left in the auto position
http://www.ebay.com.au/itm/Automatic-He ... 2236559578

does not seem to be one for the Colorado but the idea is the same.

something could be made using a relay and a light sensor and some other bits.
you would just leave the headlight switch in the on position and control the wire that turns the lights on with the relay.

I would make one using an arduino board that would wait for the light sensor to below or above a certain level of light for about 15 seconds before switching the lights on or off so they don't switch on and off like crazy.
the commodore takes about 10 to 15 seconds.

i might toy around with making one as i have some arduino gear around.

i made this a little while ago for my series 1 commodore.
https://forums.justcommodores.com.au/th ... up.256284/

the Colorado has that function where you hold the window up button for 1 second and the window goes into an auto close mode so you don't have to hold the button. the series 1 commodore does not so using arduino and some relays i replicated that function.

auto headlights is pretty much going to be a similar thing but instead of holding a switch to trigger the relay a light sensor would trigger it.
the main problem will be getting the light sensors level right so street lights don't switch them off but they switch off during the day.

SomeCant
Been here a while
Posts: 173
Joined: May 5th, 2014, 4:09 pm
Location: WA

Re: Mylink Dev Mode Help needed?!

Unread post by SomeCant » March 1st, 2017, 5:51 pm

had some spare time today to play with arduino.
this is what I was talking about with the light sensor and arduino boards.

https://youtu.be/ZT5DfItc8oI

this circuit will turn the lights off and on depending on the level of light that hits the sensor and that light has to be above or below a certain level for 10 seconds before it will trigger the change.
as you can see putting my finger over the light sensor to simulate night time triggers the change.

this is just a test platform using my biggest arduino boards with the lcd debug output, it can be made much smaller as it does not need the lcd screen and 4 relays.
now its just a matter of mounting the light sensor in the vehicle and testing the level of light for the change, lucky enough I have a vehicle with auto headlights so I can try and match that level as close as I can.

SomeCant
Been here a while
Posts: 173
Joined: May 5th, 2014, 4:09 pm
Location: WA

Re: Mylink Dev Mode Help needed?!

Unread post by SomeCant » March 3rd, 2017, 3:39 am

worked out the right light settings it worked well doing a debug test printing the data and switch state to the lcd screen, got it to match the vf commodores auto headlights almost perfectly.

so I have built the module.
Image

its cost $40 in parts at jaycar to build it and might be another $5 or $10 for a plastic case at jaycar to put it in but I have a few of those.

once I install it into my Colorado and test it with the headlight switch connected I will post the schematics and scripts needed to build the module and program it.

SomeCant
Been here a while
Posts: 173
Joined: May 5th, 2014, 4:09 pm
Location: WA

Re: Mylink Dev Mode Help needed?!

Unread post by SomeCant » March 3rd, 2017, 3:44 pm

I should have expected this in a new vehicle, the Colorados headlight switch is actually a canbus module.
it turns the lights on and off using canbus messages so its not your old traditional type of switch and I guess that's why there are no auto headlight kits floating around because you would need to interface with the ecu/bcm via the canbus and send the right data packets telling the headlights to turn on.

but lucky enough the switch holds its state and sends the packets down the canbus when you disconnect the swcan wire and reconnect it.
so this auto headlight module still works by disconnecting the swcan wire and reconnecting it.

the good thing is its only 1 green wire on the back of the headlight switch that needs to be cut to toggle the lights on and off :)

here is a video of a test of it in the vehicle using a floodlight to simulate daylight to the light sensor.
https://youtu.be/MIVDvRXNF0o

now I need to go driving to test it properly.

something else that might be needed is a way to override the module to force the headlights switch on if needed.
maybe a simple switch to connect the swcan wire overriding the relay in the module so the vehicles headlight switch operates like normal.

Peter Aawen
Admin
Posts: 20807
Joined: June 17th, 2005, 8:01 pm

Re: Mylink Dev Mode Help needed?!

Unread post by Peter Aawen » March 3rd, 2017, 6:07 pm

While these canbus things might make vehicles cheaper & easier to make, even arguably more reliable, they certainly don't help make things any less complicated to play with!! :rolleyes:
An Ex-Service person is someone who thought enough about their country & how great it is, how lucky we are to live here, to write a blank cheque made out to 'The People and Commonwealth of Australia' for the value of 'Up to & including my Life!'

muskrat
Getting to know the place
Posts: 16
Joined: May 20th, 2014, 8:20 am

Re: Mylink Dev Mode Help needed?!

Unread post by muskrat » March 6th, 2017, 11:59 am

Really interested to see how you go getting MirrorLink to work. I have seen a couple of youtube vids (one in Russian unfortunately). Are you following what this guy has done:
https://sourceforge.net/p/mylink-unlock ... wiki/Home/
2014 RG Colorado LT Dual Cab. ARB Canopy, Towbar.

SomeCant
Been here a while
Posts: 173
Joined: May 5th, 2014, 4:09 pm
Location: WA

Re: Mylink Dev Mode Help needed?!

Unread post by SomeCant » March 6th, 2017, 1:41 pm

yep that's the work on the chevy mylink.
the Russian firmware is a little different to ours so there is some issues.

I managed to get mirrorlink with android 5.1.1 and 6.0.1 working but its very restricted most of the known mirrorlink hacks to enable full phone mirroring don't work.

just waiting for my 2nd mylink and eeprom programmer to arrive now.

muskrat
Getting to know the place
Posts: 16
Joined: May 20th, 2014, 8:20 am

Re: Mylink Dev Mode Help needed?!

Unread post by muskrat » March 24th, 2017, 5:45 am

Hi SomeCant,

Have you made any progress on this?

Had my Colorado serviced yesterday and asked if there was a Mylink update. Yes there was! Upgraded to V23.3 but now my reversing camera doesn't work! I am dropping it back in today - hopefully the dealer knows what to do otherwise I'll get them to revert it back to the old version.
2014 RG Colorado LT Dual Cab. ARB Canopy, Towbar.

SomeCant
Been here a while
Posts: 173
Joined: May 5th, 2014, 4:09 pm
Location: WA

Re: Mylink Dev Mode Help needed?!

Unread post by SomeCant » March 24th, 2017, 8:43 am

version 23 works with the reverse cam they probably just forgot to enable it.

as for mirrorlink I have got that working and managed to get the phones launcher to display on the mylink, also have hema explorer working and android auto.
there is a lot of modification to the phones mirrorlink app needed to allow apps to run on the mylink.
the mylink is very laggy too so you cant play video using mirrorlink, most other apps work fine.
in its current form its a bit much for the average person to get it working because there is a lot involved to get a non mirrorlink certified app to run but I am working on it.


Image
Image
Image

muskrat
Getting to know the place
Posts: 16
Joined: May 20th, 2014, 8:20 am

Re: Mylink Dev Mode Help needed?!

Unread post by muskrat » March 24th, 2017, 10:47 am

That's awesome. Keep us posted.
2014 RG Colorado LT Dual Cab. ARB Canopy, Towbar.

muskrat
Getting to know the place
Posts: 16
Joined: May 20th, 2014, 8:20 am

Re: Mylink Dev Mode Help needed?!

Unread post by muskrat » March 24th, 2017, 10:54 am

Quick question - does Android Auto play nicely with MirrorLink? Because that's all I'm really interested in implementing.

Also - did you try following those instructions on Source Forge to see if that would work with V23 MyLInk?
2014 RG Colorado LT Dual Cab. ARB Canopy, Towbar.

SomeCant
Been here a while
Posts: 173
Joined: May 5th, 2014, 4:09 pm
Location: WA

Re: Mylink Dev Mode Help needed?!

Unread post by SomeCant » March 24th, 2017, 3:02 pm

android auto seems to run fine through mirrorlink but I have only bench tested it so far(not in vehicle)

i have not tried anything else so far with the vehicle as i am working with getting android apps to work.

muskrat
Getting to know the place
Posts: 16
Joined: May 20th, 2014, 8:20 am

Re: Mylink Dev Mode Help needed?!

Unread post by muskrat » May 2nd, 2017, 7:20 am

Hi SomeCant. Have you made any further progress with this?
2014 RG Colorado LT Dual Cab. ARB Canopy, Towbar.

Return to “Colorado”