Page 14 of 14

Re: Wierd goings on... 4x4 & 4L lights staying on! Any ideas?

Posted: July 19th, 2018, 7:00 pm
by suzygs1000
IMG_0177.JPG
Hi, Guys,

I recently experienced this problem in my PJ Ranger with 149 k's on the clock.

After reading through this, I searched on Ebay for the Transfer Case module.

There are a number of them listed, ranging from $1800 to $225. Being a tight arse, I purchased the $225 one, which was listed as a Great Wall part.

The unit fitted perfectly, all wiring was correct, and the job took about an hour altogether.

It fixed the problem.

I pulled the original item to pieces, as it is a sealed unit, I had to wreck it to get at the switch. Inside, there is what appears to be a fibrous washer over the shaft which fits into the gear.

This fibrous washer had come to bits, and there were bits of fibrous matter floating around everywhere, including under the sensor strips.

I have taken a photo of the failed part, but cannot see how to post the photo.

Anyway, if any one suffers this problem in the future, don't muck around with electronic modules or relays, just replace the transfer case module.

I also noted that someone had purchased one for about $70 from Aliexpress.

The module is identical to the Borg Warner item, but has a slightly different brand name, which I cannot recall at the moment.




regards Dave.

Re: Wierd goings on... 4x4 & 4L lights staying on! Any ideas?

Posted: July 19th, 2018, 7:01 pm
by suzygs1000
Obviously, I worked out how to post pics ....

Re: Wierd goings on... 4x4 & 4L lights staying on! Any ideas?

Posted: September 10th, 2018, 7:33 pm
by arief
HI Suzygs1000,

do you mean, you replaced the transfer case 4X4 Shift Motor?

Re: Wierd goings on... 4x4 & 4L lights staying on! Any ideas?

Posted: November 14th, 2018, 7:44 am
by Robbieraven
Hi Guys,

For Dr Fleetwood (Rob) mainly :) Hope he is still on the forum.

Just bought a 2007 Ranger PJ 5 Speed Auto about a month ago, all in great condition but the previous owner was good enough to say: "there is a weird thing that happens every now and then" yes you guessed it :)

Anyway, had no issues in the first month, until yesterday. Yep, low 4 light comes on and speedo freaks out. Have done a bit of mechanical bits in the past but I did think this was weird. Ah well speak to Google and I was so surprised to find this thread with all the exact symptoms. Any got hold of a T15 bit and turns out it was a T30 that was needed for mine, I loosened and adjusted the offending plate as described by Rob (by fleetwood ยป May 30th, 2015, 5:48 pm)

Bang the light, went off, am off to do a road test in a while but thought I'd report back so far. As far as I could tell the plate on mine seemed to be plastic but I didn't remove it fully, just moved it within the slots. All good so far, so i too said something like: "This guy is a legend" thanks Rob

I'll keep you posted guys.

Cheers Rob (2)

Re: Wierd goings on... 4x4 & 4L lights staying on! Any ideas?

Posted: November 14th, 2018, 8:39 am
by Robbieraven
Ok all good so far guys, thanks again Dr Fleetwood

Re: Wierd goings on... 4x4 & 4L lights staying on! Any ideas?

Posted: November 15th, 2018, 9:46 pm
by fleetwood
Hi Robbie...

Yep still pop in from time to time..

Good to hear the quick fix worked for you... If the problem becomes really persistent you can dismantle & clean the offending parts... I haven't needed to so far. Just make sure you always have that torx driver with you LOL

Cheers for the thank you