Ford Falcon auto box problem

For the Ford folk!
Bevan'n'Katie
Avid Poster
Posts: 682
Joined: March 26th, 2012, 9:55 am
Location: Townsville

Ford Falcon auto box problem

Unread post by Bevan'n'Katie » October 21st, 2012, 2:12 pm

i know this isnt a 4wd but i dont wanna join another forum just to get advice because everyone here would have a town car as well.

anyways driving home yesterday my 1999 ford falcon lost power, it wouldnt rev or anything, then they gear box seemed to jump in and out of drive and then all of a sudden it would be back to normal. the 5 mins later it would do it again. i drove around 300km yesterday and it was the last 60km that it done this. iv jacked it up and there looks to be some oil under the car but none on the ground where its parked. would low oil cause this problam ? but also why wouldnt the car rev. the revs dropped down to idle when this happend. i didnt try putting it into N while movinig to see if it would rev just waited for it to come good again. any info or anythink you guys can think of would be great

Cheers
Bevan

Peter Aawen
Admin
Posts: 20812
Joined: June 17th, 2005, 8:01 pm

Re: Ford Falcon auto box problem

Unread post by Peter Aawen » October 21st, 2012, 2:43 pm

Low fluid in the box will certainly do things like that, so will overheating the box, especially if the fluid is down; basically the engine control is telling the engine to shut down before destroying the box. Sounds very much like it's major auto trans service time!! Give the guys at Wholesale Automatics a call if you want to talk about the possible problems & fixes, they are usually very helpful and often can even recommend someone nearby to take your vehicle to in order to get it all sorted. There is a small article in the latest Mag - 'Repair or Replace', Issue 189 page 224 ;)
An Ex-Service person is someone who thought enough about their country & how great it is, how lucky we are to live here, to write a blank cheque made out to 'The People and Commonwealth of Australia' for the value of 'Up to & including my Life!'

Bevan'n'Katie
Avid Poster
Posts: 682
Joined: March 26th, 2012, 9:55 am
Location: Townsville

Re: Ford Falcon auto box problem

Unread post by Bevan'n'Katie » October 21st, 2012, 8:01 pm

cheers for the info mate, ill have a look in the mag as well

Return to “General Ford”